
Introduction

comPARAFingerprint , comPARAPalmprint , comPARAPrint TECH+ and comPARAPrint TECH+ DB are a family of programs 
designed to allow comparison of finger, and/or palm prints on desktop or portable PC’s. Designed as a high performance tool to aid 
the latent examiner, 

In combination with a scanner or video capture device, prints can easily and rapidly be brought into the computer, have features 
extracted and be compared against any other stored print.

Each of the four programs uses Sirchie’s sophisticated AFIS-grade feature extraction engine. This engine automatically detects and 
eliminates questionable areas of the print, including smudges, so that they will not be considered in the comparison. Technicians 
can easily intervene override such decisions. Points of minutia are located using sophisticated rules based on the cumulative 
knowledge of expert examiners. Technicians are given full freedom to add to or remove from the automatically generated set of 
minutiae.

Processing an image (that is, extracting its features) generates data detailing the coordinates and directions of the features, as well 
as three types of enhanced images: a binary representation, an embossed representation showing the print minus areas judged to 
be bad, and a skeletal image. The binary image results from the application of sophisticated process which first determines what 
areas of the print constitute ridges and what constitute background, and then removes the background while enhancing the ridges. 
The skeletonized, or thinned image, is the result of a process that removes extra pixels and produces a simpler image still made up 
entirely of pixels belonging to the skeleton of the object. Image enhancement algorithms offer the examiner different views of the 
print to aid in his decision to add or remove points of minutia.

All data extracted by the comparison engine or modified by the examiner can be stored as a data set, which means that your work is
immediately available to you for later comparisons without having to repeat the processing.

Sirchie’s AFIS-grade comparison engine is able to rapidly compare prints, compensating for the distortions inherent in latent and 
rolled prints, and uncertainties in relative rotation to provide a graded measure of the similarity of the two prints. The AFIS-grade 
comparison engine automatically makes a statistical comparison of the two prints, displaying a goodness rating for the comparison. 
In addition, a graphical overlay shows just what the comparison engine used as the basis of its decision, allowing intervention by the
technician as desired. Comparisons can be made on the basis of the full latent, or on any user-defined portion of the latent.

Printouts of any of the computer generated images, including those showing points of minutia are available via any graphics-
capable, Windows-compatible printer. Printouts of any screen, including side-by-side display of the reference and latent prints are 
also immediately available.

Prints can be stored as Windows bitmap, JPEG, Tiff or TARGA files for export to other graphics software.

Salient Features
Software automatically adjusts window size to your monitor's resolution.

Acquire images via any TWAIN-compliant device capable of 600 dpi resolution. Free-form input area allows you to acquire the full 
impression or latent or any part of it.

View prints side-by-side over a large range of magnifications.

Automatically extract features such as ending ridges, islands and bifurcations.

Manually add or delete features.

Choose areas of the print to be ignored by the feature extraction and feature comparison engines.

Adjust image Brightness, Contrast and Sharpness for best feature extraction
View or print Grayscale, Binary, Enhanced or Skeletonized images of ridge structure.

Load and then automatically compare latent and reference prints.

Automatically compare prints based on a region of the latent.

View or print matrix of lines and features used in making match.

Export images in JPEG, TIFF, or BMP formats.

Prepare courtroom presentations by printing latent print, reference print, or the screen to any Windows-compatible graphics printer. 

Print any image that can be displayed on screen.

Save processed prints as datasets containing processed images and full data on automatically and manually extracted features 
(coordinates and direction vectors) for rapid reload and comparison.



Which program is right for you?
comPARAFingerprint is Sirchie's premier finger print comparison software. comPARAFingerprint features state-of-the-art feature 
extraction and comparison engines particularly tuned to fingerprints, automatic handling of latent rotation and an easy to learn 
interface. Load a print into the ‘known’ window and rapidly compare a latent against it. If your day-to-day workload is modest, and 
consists primarily of fingerprints, this is the choice for you. 

comPARAPalmprint is Sirchie's premier palm print comparison software. comPARAPalmprint features state-of-the-art feature 
extraction and comparison engines particularly tuned to palm prints , automatic handling of latent rotation and an easy to learn 
interface. More often than the fingerprint examiner, the palm print examiner often faces the daunting task of determining the relative 
rotation of the lifted portion of a palm print to the full impression. comPARAPalmprint easily and rapidly accomplishes this task, 
even if the latent consists of widely separated areas of minutia on a single lift. Load a print into the ‘known’ window and rapidly 
compare a latent against it. If you day-to-day workload is modest and consists primarily of palm prints, this is the choice for you. 

comPARAPrint TECH + combines Sirchie's premier fingerprint and    palm print comparison software. Choosing the properly tuned 
feature extraction and comparison engines is as easy as clicking a mouse button. Stored prints ‘remember’ their type and 
automatically call the proper extraction and comparison engine on being loaded. Load a print into the ‘known’ window and rapidly 
compare a latent against it.    If you day-to-day workload is modest and consists of a strong mix of palm prints and fingerprints, this is
the choice for you.

comPARAPrint TECH+ DB combines Sirchie's TECH+ software with a database capable of holding 500 prints. With the database 
capability, comparisons between a latent and the prints in the database is made at the click of a button, without having to manually 
load each ‘known’ print, and with graded results posted. Results can be called to the screen one at a time for review by the 
examiner.

Purchase Information



Main Screen

Main Screen

The Main Screen is the default screen for the program. This screen consists of several objects including 
the Main menu, the Build Control dialog, the Mode dialog, the Gallery, the working window, the Tool Bar, 
the tool function display, and the Current Component Gallery. With the exception of paint and edit 
operations in captured images, all Capture mode functions are selected from this dialog.

The following describes its functionality:
1. Menu Bar: The horizontal bar across the top of the screen which lists the categories or groups of 
functions available.
2. Mode Selection Buttons: comPARAPrint® TECH+ offers two modes: Fingerprint and Palmprint.
Select the desired mode by clicking on the appropriate button. Note that the Mode buttons appear 
only in comPARAPrint Tech+ software.
3. Recorded Window: The window into which the known print is loaded and processed.
4. Latent Window: The window into which the latent (unknown) print is loaded and processed.
5. Zoom Sliders: Allow magnification of the Recorded image (leftmost slider) Latent image 
(rightmost slider) or synchronized magnification of both images (center slider). 

6. Main Toolbar: An area at the top of the main screen that displays action buttons which activate 
the various functions available to you. Functions available include the Deselect, Add Features, 



Remove Features, Add/Move/Delete Core, Process Area of Interest, Redefine Bad Areas, Create 
Rectangular Area, Create Freehand Area, Create Elliptical Area, Define Functionality, Start New 
Region, Add to Region, Subtract from Region, Display Match Matrix, and Display Descending Match.
7. Window Toolbars: An area at the side of each window that displays action buttons which activate 
the various functions available to you. Functions available include Feature Count, File Open, Extract 
Features, Remove Features, Hide Features, Show Original Image, Show Binary Image, Show Bad 
Areas, and Show Skeletonized Image.
8. Compare Button: Causes a comparison between the Latent and Recorded images to be 
performed. 
9. SIM Display: Displays the “goodness” of the comparison. Generally, the higher the number, the 
better the match.
10. Graphical Display: Graphically displays the “goodness” of the comparison. A red final bar 
indicates an very high probability.



Mode Selector buttons (comPARAPrint Tech+ only)

The Mode Selector buttons are located at the top of the main window, and allow you to select between 
Fingerprint and Palmprint modes.

To Select the Fingerprint mode, 
1. Click over the Fingerprint mode button.
2. Open a fingerprint data set.

If a palm print is already loaded, you are asked if you wish to remove the existing data. If you select yes, 
the existing data is removed. The Fingerprint mode button appears as though depressed.

To Select the Palmprint mode, 
1. Click over the Palmprint mode button.
2. Open a Palmprint data set.

If a fingerprint is already loaded, you are asked if you wish to remove the existing data. If you select yes, 
the existing data is removed. The Palmprint mode button appears as though depressed.



Compare Button and Comparison Results (SIM) display.

When both the REC and LAT windows have been loaded, and features for each have been extracted via 
the respective EX buttons, a comparison between the two prints can be made. 

The comparison engine is launched via the Compare button. When a comparison is made between a 
print and a latent, the comparison engine reports a number that represents the goodness of the resulting 
match. This result is displayed in two ways: as a number, and as a bar graph. In general, the higher the 
number, the more likely the two prints are to match.



Comparing a latent to a recorded print.

Once features have been extracted to your satisfaction, the comparison engine is launched by simply 
clicking on the Compare button on the Main Window. The comparison engine will display a number in the
SIM window that represents the goodness of the match; a higher number represents a greater likelihood 
of a match. In addition, a bar graph displays similar information. A red bar in the last position indicates an 
exceedingly high likelihood of a match.

Considerations in Palm print Mode



Comparison in Palm print Mode

In Palm print Mode, when a comparison is successfully made (at least a score of fifteen is generated), a 
rectangle is generated in the Recorded window to show you the general area where the match occurred. 
If you click on the Mx or Yn buttons, the area within the rectangle will be shown enlarged in the Recorded 
window with the appropriate lines display superimposed.

Box (blue) generated to illustrate the general area of the successful comparison.



Main Menu

The main menu groups are File, Image, View, and Help  .   

To select a main menu group:
1. Place the pointer over the desired menu group. [The corresponding option will become highlighted.]
2. Click the left mouse button. [A list of options drops down.]
Or
2a. While holding the Alt key down, depress the letter underlined on the desired main menu group. For 

example, if you wish to access the File group, hold down the Alt key and depress the ‘F’ key on the 
keyboard. [A list of options drops down.]



File group options

Selecting the File group on the main menu causes a number of related options to appear.
The File group options include:

Open Image Opens an existing image
Open Data Set     Opens an existing data set
Save Original Image Saves the original (unprocessed) image
Export Export any of the four processed images
Save Data Set      Save a processed image as a data set
Print Print recorded or latent image or the screen 
Printer Setup … Set your printer parameters
Acquire Acquire an image from either video or a page scanner
Select Source … Select your TWAIN compliant source
Exit. Exit the program



Open Image
Opens an existing image

Image files are files generated via the Acquire function and are saved via the Save Original Image 
function. Image files can be Tiff, Windows bitmap, or JPEG formats.
1. With the File menu dropped, place the mouse over the option Open Image
Or
1a.    With the File menu dropped, type O
2. if the image is to be loaded into the Recorded window, select Recorded or type R
Or
2a. If the image is to be loaded into the Latent window, select Latent or type L
The File Open dialog will be generated
3. Locate and click or double-click on the filename of the desired file, or type the desired filename into 

the Filename field.
4. Click on Open. (Note: if you double-clicked on the filename, the file will load automatically.)
The image will be loaded into the appropriate window.



Open Data Set
Opens an existing data set

A comPARAPrint data set consists of the four processed images (original, binary, bad and skeletal) and 
the extracted features for a print. This type of file is generated via the Save Data Set function.

1. With the File menu dropped, place the mouse over the option Open Data Set
Or
1a.    With the File menu dropped, type t
2. if the image is to be loaded into the Recorded window, select Recorded or type R
Or
2a. If the image is to be loaded into the Latent window, select Latent or type L
The File Open dialog will be generated, displaying all files with the extension “.dts”
3. Locate and click or double-click on the filename of the desired file, or type the desired filename into 

the Filename field.
4. Click on Open. (Note: if you double-clicked on the filename, the file will load automatically.)
The image will be loaded into the appropriate window.



Save Original Image
Saves the original (unprocessed) image

1. With the File menu dropped, place the mouse over the option Save Original Image
Or
1a.    With the File menu dropped, type S
2. if the image is to be saved is in the Recorded window, select Recorded or type R
Or
2a. If the image is to be saved is in the Latent window, select Latent or type L
The File Save dialog will be generated
3. Choose the desired storage folder for the file
4. Choose the format you wish to save the file in (the default is Windows bitmap)
5. Type in the name for the file
6. Click Save
The file is saved to the indicated location. This type of image can be accessed through the Open Image 
function (see above).



Save Data Set
Save a processed image as a data set

1. With the File menu dropped, place the mouse over the option Save Data Set
Or
1a.    With the File menu dropped, type D
2. if the image is to be saved is in the Recorded window, select Recorded or type R
Or
2a. If the image is to be saved is in the Latent window, select Latent or type L
The File Save dialog will be generated
3. Choose the desired storage folder for the file
4. Type in the name for the file
5. Click Save
The file is saved to the indicated location. This type of image can be accessed through the Open Data Set
function (see above).



Export

Export any of the processed images

1. With the File menu dropped, place the mouse over the option Export
Or
1a.    With the File menu dropped, type E
2. if the image is to be saved is in the Recorded window, select Recorded or type R
Or
2a. If the image is to be saved is in the Latent window, select Latent or type L
An image type menu will be generated.
3. To save the original image, select Original or type O 
3a. To save the binary image, select Binary or type B 
3b. To save the marked bad areas image, select Bad or type a 
3c. To save the skeletal image, select Skeletal or type S 
3d. To save the compared lines (Mx or Yn) image, select Compared Lines... or type C 
The File Save dialog will be generated
4. Choose the desired storage folder for the file
5. Choose the format you wish to save the file in (the default is Windows bitmap)
6. Type in the name for the file
7. Click Save

The file is saved to the indicated location. This type of image can be accessed through the Open Image 
function .

Examples of exported image of the Binary display of the fingerprint





Print
Print recorded or latent image or the screen 

1. Select the type of image to be printed by selecting the OR  ,   BI  ,   BD   or   SK   buttons on the appropriate 
window.

2. With the File menu dropped, place the mouse over the option Print
Or
2a. With the File menu dropped, type P
3. if the image is to be printed is in the Recorded window, select Recorded or type R
Or
3a. If the image is to be printed is in the Latent window, select Latent or type L
The image will be sent to your printer.



Printer Setup…
Set your printer parameters

1. With the File menu dropped, place the mouse over the option Printer Setup…
Or
1a.    With the File menu dropped, type S two times
The Windows printer setup dialog will be displayed. Set the printer to the desired parameters.



Acquire
Acquire an image from either video or a page scanner

With the File menu dropped, place the mouse over the option Acquire
Or
1a.    With the File menu dropped, type A
if the image is to be acquired from a video capture device, select Video Capture or type V
Or
2a. If the image is to be acquired from a page-scanning device, select Page Scanner or type P
if the image is to be loaded into the Recorded window, select Recorded or type R
Or
3a. If the image is to be loaded into the Latent window, select Latent or type L

Your TWAIN source’s software will be launched. Follow its procedures to obtain an image.



Select Source...
Select your TWAIN compliant source

1. With the File menu dropped, place the mouse over the option Select Source…
Or
1a.    With the File menu dropped, type S three times
The Select Source dialog is generated.
2. Click on the source you wish to employ for this image acquisition.
The selected source will be highlighted
3. Click on the Select button.
The chosen source is ready to be accessed in the next Acquire operation. 



Exit.

Exit the program

1. With the File menu dropped, place the mouse over the option Exit
Or
1a.    With the File menu dropped, type x

The program will close.



Image group options

Selecting the Image group on the main menu causes four related options to appear.
The Image group options include:

Reverse display the image as a negative
Restore to Original restore the image you entered the program with
Flip Horizontal flip the existing image left to right
Flip Vertical flip the existing image top for bottom
Brightness adjust brightness of the image
Contrast adjust contrast of the image or a selected portion of the image
Sharpen sharpen the image or a selected portion of the image



Reverse
display the image as a negative

The Reverse function applies to the whole image only.
1. With the Image Adjustment menu dropped, place the mouse over the option Reverse
Or
1a.    With the Image menu dropped, type R
2. if the image to be reversed is in the Recorded window, select Recorded or type R
Or
2a. If the image to be reversed is in the Latent window, select Latent or type L
The image is reversed (negative for positive).

Original image Reversed image

Restore to Original
Return to the originally scanned image

The Restore to Original function applies to the whole image only. It removes all processing which has 
been applied and all four processed images (OR, BI, BD, and SK) associated with it.
1. With the Image Adjustment menu dropped, place the mouse over the option Restore to Original
Or
1a.    With the Image menu dropped, type E
2. if the image to be restored is in the Recorded window, select Recorded or type R
Or
2a. If the image to be restored is in the Latent window, select Latent or type L
The image is restored as though it had just been acquired without any extracted features or processed 
images.



Brightness

Adjust brightness of the image

The Brightness function applies to the whole image only.

1. With the Image menu dropped, place the mouse over the option Brightness
Or
1a.    With the Image menu dropped, type B
2. if the image to be sharpened is in the Recorded window, select Recorded or type R
Or
2a. If the image to be sharpened is in the Latent window, select Latent or type L
The Brightness dialog will open.
3. Position the slider to achieve the desired degree of brightness. Note that the effect is previewed on 

the appropriate image.
4. Click OK to keep the altered image.

The Brightness Dialog.



Contrast

Adjust contrast of the image

The Contrast function applies to the whole image.

1. With the Image menu dropped, place the mouse over the option Contrast
Or
1a.    With the Image menu dropped, type C
2. if the image whose contrast is to be adjusted is in the Recorded window, select Recorded or type R
Or
2a. If the image whose contrast is to be adjusted is in the Latent window, select Latent or type L
The Contrast dialog will open.
3. Position the slider to achieve the desired degree of contrast. Note that the effect is previewed on the 

appropriate image.
4. Click OK to keep the altered image.

The Contrast dialog.



Sharpen

Sharpen the image

The Sharpen function applies to the whole image.
1. With the Image menu dropped, place the mouse over the option Sharpen
Or
1a.    With the Image menu dropped, type S
2. if the image to be sharpened is in the Recorded window, select Recorded or type R
Or
2a. If the image to be sharpened is in the Latent window, select Latent or type L
The Sharpen dialog will open.
3. Position the slider to achieve the desired degree of sharpening. Note that the effect is previewed on 

the appropriate image.
4. Click OK to keep the altered image.

The Sharpen dialog.



View group options

Selecting the View group on the main menu causes a number of related options to appear. This menu 
group is available only in the TECH+ DB version of the software.
The View group options include:

Database View  Causes the Database window to be displayed
Search Database Causes the current Latent to be searched against the print database



Database View

Selecting the Database View option on the View option group causes the Database Window to be 
displayed. In this view, prints loaded into the Recorded window can be added to the Recorded database, 
prints loaded into the Latent window can be loaded into the Latent Database, and Searches against the 
database can be performed.

The Database View. The Latent Database entries appear in aqua (right of the screen), the Recorded Database in Gold (left of the 
screen), and the Match Candidates appear in green (left of the screen) 



Searching a Latent against the Recorded Database

Any latent in your Latent Database can be searched against the Recorded Database. To Search:

1. Load the desired print from the Latent Database.
2. Select View/Search Database/ on the Main Menu. The Similarity Filter dialog will appear.
3. Enter the number for the lowest similarity you wish to accept and click on OK. The search will execute 
against prints of the same type (finger or palm) in the Recorded database. Any print found to have a 
similarity greater than or equal to the value you entered for the lowest similarity will be added to the Match
Candidates Database, and be displayed in the Match Candidate window.
4. Load any print from the Match Candidates database for further study.



Help group options

Selecting the Help group on the main menu causes two related options to appear.
The Help group options include:

About Displays information about the release of the software
Help Topics… Launches the program’s help file



Main Toolbar

The Main Toolbar allows access to functions which can be used on either the Recorded print or the Latent
print. 

Left to right, these functions include:

Deselect all tools

F/P modes Makes all tools inactive; releases an Area of Interest

Manually ADD features 

F/P modes Allows you to add features to a print manually

Manually REMOVE features

F/P modes Allows you to remove features from a print manually

Process area of interest on latent

F/P modes Select an area of the Latent to compare against the Recorded

Redefine Bad Areas

F/P modes Add or Remove selected area to or from Bad areas

Define rectangle

F/P modes Define a rectangular region on the window

Define Freehand

F/P modes Define an arbitrary region on the window

Define elliptical

F/P modes Define an elliptical region on the window

Add/Remove

F/P modes Define the functionality of the Redefine Bad Areas tool

Start New Region (=)

F/P modes Create a new region, discarding any existing region

Add to Existing Region (+)

F/P modes Add the next area to an existing region

Subtract from existing region (-)

F/P modes Subtract the next area from an existing region

Display Match Matrix (Mx)

F/P modes Show the matrix of features used in determining the match

Display Descending Match (Yn)

F/P modes Show features used in match in horizontal order



Adding/Removing Features, and Repositioning the Center manually.

While current technology is very good at extracting features and ignoring noise, no extraction engine 
approaches a skilled technician except in speed. All versions of comPARAPrint allow for the addition of 
and the removal of features.

WARNING: Make manual adjustments to the feature set only after you are satisfied with the automatic 
extraction and the marking of good and bad areas. Features added or removed manually will be lost if the
automatic extraction engine is run.

Adding Features
1. Select the Add Feature tool on the Main Toolbar
2. Magnify the image as desired.
3. Position the pointer over the feature of interest
4. Click over the feature and drag the mouse in the direction of the feature. In the case of an ending 

ridge, drag to show the direction of the ridge (that is, start from the end, drag back up the ridge); in the
case of a bifurcation, split the Y. Another way to think of how to mark a bifurcation is to image its 
negative, so that instead of, say, black ridges splitting to form a bifurcation you have a white ending 
ridge surrounded by black: then just mark this ending ridge as usual).

Ending Ridge (or white bifurcation?) Bifurcation (or white Ending Ridge?)

5. Release the mouse button. The feature will be added.

Removing Features 
1. Select the Remove Feature tool on the Main Toolbar
2. Magnify the image as desired.
3. Position the pointer over the feature to be removed
4. Click the mouse button. The feature will be removed. Note: To remove multiple features, drag the 

mouse to ‘paint’ over the features to be removed. All features along the path drawn will be removed. 



To ADD a bad area (an area for the extract engine to ignore):

1. Select the original image by clicking on the OR button on the Window Toolbar.
2. Choose the Add option in the combo box on the Main Toolbar
3. Choose the equal sign (=) button to the right of the combo box. 
4. Choose a region-generating tool, such as the Rectangle tool, the Freehand tool or the Ellipse tool, 

by clicking on it.
5. Draw a region around the area you wish to mark as bad. 
5a. To add or subtract from the area you have drawn (i.e. to create complex areas) use the plus (+) and 

minus (-) buttons to add or subtract respectively from the region created with the equal (=) button 
active.

6. When you have created the desired region, click on the Redefine Bad Areas tool on the Main 
Toolbar. The extract engine will perform n extraction disregarding areas marked as bad.

Areas marked for the extraction engine to ignore (marked as 'Bad') in its search for features are shown in 
green when the BD image is selected on the Window Toolbar. Areas automatically set by the extraction 
engine can be modified using functions on the Main Toolbar, as described above. Areas can be simple or 
complex.

Bad areas as marked by the automatic 
extraction engine

Simple rectangular area Added to the bad
area

Complex set of bad areas added using 
the + and - functions

To REMOVE a bad area or a portion of an area marked as bad:

1. Select the original image by clicking on the OR button on the Window Toolbar.
2. Choose the Remove option in the combo box on the Main Toolbar
3. Choose the equal sign (=) button to the right of the combo box. 
4. Choose a region-generating tool, such as the Rectangle tool, the Freehand tool or the Ellipse tool, 

by clicking on it.
5. Draw a region around the area you wish to remove from the area marked as bad. 
5a. To add or subtract from the area you have drawn (i.e. to create complex areas) use the plus (+) and 

minus (-) buttons to add or subtract respectively from the region created with the equal (=) button 
active.

6. When you have created the desired region, click on the Process Defined Region tool on the Main 
Toolbar. The extract engine will perform an extraction adding the marked region back into the area 
from which to extract features.



Comparing a portion of a latent print to a recorded print

1. Click on the Process Area of Interest button on the Main Toolbar.
2. Drag the mouse to create a rectangular area of interest on the latent print. 
3. Release the mouse button. A comparison will be made between the area of interest defined and the 

reference print. 
4. Repeat as desired.
5. To undo the area of interest and return to your starting point, click on the No Tools Selected tool on 

the Main Toolbar.



Display Match Matrix (Mx)

If, during the Compare operation, a likeness score of fifteen (15) or greater is obtained, the Mx button on 
the Main Toolbar is enabled. Clicking on it causes the matrix of lines between features used by the 
comparison engine to be displayed as shown below. This display allows you to see what the engine is 
basing its comparison score on, so that you can judge the comparison for yourself. These images can be 
saved via the Export command.

Recorded Latent

Display Descending Match (Yn)

If, during the Compare operation, a likeness score of fifteen (15) or greater is obtained, the Yn button on 
the Main Toolbar is enabled. Clicking on it causes the features used by the comparison engine to be 
displayed in order of their Y-coordinate, as shown below. This display allows you to see what the engine is
basing its comparison score on, so that you can judge the comparison for yourself. These images can be 
saved via the Export command.

Recorded Latent



Marking areas of the print as bad

Marking areas of a print as bad instructs the feature extraction engine to ignore those areas. To mark an 
area as bad, you must first load or acquire an image, adjust rotation, brightness, contrast and sharpness 
as desired, and run the extraction engine. Running the extraction engine creates four distinct images 
(original, binary, bad and skeletal), along with a dataset of coordinates and direction vectors for features. 
Once the Bad image has been created, you can add or subtract “bad” areas. 

Marking an area as "Bad"

Unmarking an area previously marked as "Bad"



Window Toolbars

Each window has an associated toolbar. From top to bottom, the tools are:

Function Symb
ol

Window Description

Window Name REC 
or 
LAT

Tells which window the toolbar works on

Feature Count field - REC/LAT Displays the number of features the extract engine located

File Open REC/LAT Calls the File Open dialog

Extract Features REC/LAT Activates the feature extraction engine

Remove Features REC/LAT Permanently removes all extracted features

Show Hide Features toggle REC/LAT Shows (down) or Hides (up) extracted features

Show Original Image REC/LAT Shows features over the original image

Show Binary Image REC/LAT Shows features over the Binary image

Show Bad Image REC/LAT Shows features over the image with Bad areas marked in green

Show Skeletal Image REC/LAT Shows features over the Skeletal image

The example below is from the Latent (LAT) window



Extracting Features

comPARAPrint’s feature extraction engine is called either by clicking on the EX button present on both 
window tool bars, or by adding to or subtracting from areas declared as bad on the print. The extraction 
process is dependent on the condition of the original print, so that efforts should be made to optimize 
brightness, contrast and sharpness before the extraction engine is called. Note carefully that each time 
the extraction engine is called it discards any manual alterations you may have made. Make manual 
additions and deletions to the automatically generated feature set only after you are generally satisfied 
with the features found.



Add a Print to the Latent Database

To add a print in the Latent Database:

1. If the print has not been previously saved as a data set, create and save the dataset.
2. Open the saved dataset in the Latent Window.
3. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Place the cursor over any record in the Latent Database window, or over the bar at the top of the 
window if there are no entries and right-click. A pop-up menu will appear.

The Latent Database Window

4. Click on Add Latent. A data entry form will be displayed.

The data entry form

5. Supply the requested data. (Note: the Case Number field must be filled in.).



Add a Print to the Recorded Database

To add a print in the Recorded Database:

1. If the print has not been previously saved as a dataset, create and save the dataset.
2. Open the saved dataset in the Recorded Window.
3. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Place the cursor over any record in the Recorded Database window, or over the bar at the top of the 
window if there are no entries and right-click. A pop-up menu will appear.

The Recorded Database window

4. Click on Add Recorded. A data entry form will be displayed.

The Data Entry form.

5. Supply the requested data. (Note: the OCR Number field must be filled in.).



Delete a Print from the Latent Database

To delete a print in the Latent Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Latent Database window until the desired record is seen.

The Latent Database Window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Delete... A warning message will be displayed.
5. Confirm your intention to delete the print. Note that if a search result involves the print being deleted, 
the search result will be cleared from the Match Candidates database.



Delete a Print from the Recorded Database

To delete a print in the Recorded Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Recorded Database window until the desired record is seen.
3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Delete... A warning message will be displayed.
5. Confirm your intention to delete the print. Note that if a search result involves the print being deleted, 
the search result will be cleared from the Match Candidates database.



View Latent Database Print's Properties

To view the properties associated with a print in the Latent Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Latent Database window until the desired record is seen.

The Latent Database window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Properties... The record's properties will be displayed. Note that these are read-only.

The Properties window.

Properties explained:
The following properties are displayed in the Properties Window.

Item Definition
Version Version of the database. Updated versions may be added from time to time.
Case Case number associated with the print
Officer Officer Name associated with Case
Offense Offense associated with recorded print
Date Date of last edit.
Type 'F' (finger print) or 'P' (palm print)
Hand 'L' or 'R' if palm print, 'n/a' if finger print
Finger 'n/a' if palm print

View Recorded Database Print's Properties

To view the properties associated with a print in the Recorded Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Recorded Database window until the desired record is seen.

The Recorded Database window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Properties... The record's properties will be displayed. Note that these are read-only.



The Properties window.

Properties explained:
The following properties are displayed in the Properties Window.

Item Definition
Version Version of the database. Updated versions may be added from time to time.
OCA OCA number assigned to the print
Officer Officer Name associated with Case
Offense Offense associated with recorded print
Date Date of last edit.
Type 'F' (finger print) or 'P' (palm print)
Hand 'L' or 'R' if palm print, 'n/a' if finger print
Finger 'n/a' if palm print

Edit a Latent Database Entry

To edit a print in the Latent Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Latent Database window until the desired record is seen.

The Latent Database Window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Edit... The database entry dialog will be displayed.
5. Edit the desired field(s).
6. Click on OK to accept the changes or Cancel to exit without changing the record. Selecting OK will 
automatically update the time stamp on the record.

To edit the features associated with a latent print:
1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Latent Database window until the desired record is seen.
3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Open... The print will be loaded into the Latent window.
5. Process the print as desired.
6. Save the print as a dataset, overwriting the old file.



Edit a Recorded Database Entry

To edit a print in the Recorded Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Recorded Database window until the desired record is seen.
3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Edit... The database entry dialog will be displayed.
5. Edit the desired field(s).
6. Click on OK to accept the changes or Cancel to exit without changing the record. Selecting OK will 
automatically update the time stamp on the record.

To edit the features associated with a recorded print:
1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Recorded Database window until the desired record is seen.
3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Open... The print will be loaded into the Recorded window.
5. Process the print as desired.
6. Save the print as a dataset, overwriting the old file.



Load a Print from the Latent Database

To Load a    print from the Latent Database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Latent Database window until the desired record is seen.

The Latent Database Window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Open... The print will be loaded into the Latent window.



Load a Print from the Recorded Database

To edit the features associated with a latent print:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Recorded Database window until the desired record is seen.

The Recorded Database Window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Open... The print will be loaded into the Recorded window.



Load a Print from the Match Candidate Database

When a latent is searched against the Recorded database, candidate matches are placed in the Match 
Candidate database and displayed in the Match Candidate window. If the search results in no candidates,
no entries will be available in the Match Candidate database.

To load a print from the Match Candidate database:

1. Select View/Database View/ on the Main Menu. The database windows will appear.
2. Scroll the Match Candidate Database window until the desired record is seen.

The Match Candidate database window

3. Place the cursor over the desired record and right-click. A pop-up menu will appear.
4. Click on Open... The print will be loaded into the Recorded window.



Zoom Controls

Three zoom controls are located at the bottom of the main window. The controls with the pointed sliders 
at the left and the right can be used to independently zoom the REC and LAT respectively. The center 
control (with the square slider) zooms the two windows simultaneously.

The Zoom Controls.



Topics
Acquire an image from either video or a page scanner
ADD a bad area (an area for the extract engine to ignore):
Add a Print to the Latent Database
Add a Print to the Recorded Database
Adding/Removing Features manually.
Brightness
Compare Button and Comparison Results (SIM) display.
Comparing a latent to a recorded print.
Comparing a portion of a latent print to a recorded print
Comparing Palmprints
Contrast
Database View
Delete a Print from the Latent Database
Delete a Print from the Recorded Database
Edit Latent Database Entry
Edit Recorded Database Entry
Exit the program
Export a processed image
Extracting features
File group options
Flip Horizontal
Flip Vertical
Help group options
Image group options
Introduction
Main Menu
Main Screen
Main Toolbar
Marking areas of the print to ignore (marking as bad)
Mode Selector buttons (comPARAPrint Tech+ only)
Open Data Set
Open Image
Open (Load) a Match Candidate
Open (Load) Print from Latent Database
Open (Load) Print from Recorded Database
Printer Setup…
Print
Purchase Information
REMOVE a bad area or a portion of an area marked as bad:
Restore to Original
Reverse
Save Data Set
Save Original Image
Search Database
Select Source…
Sharpen
View group options
View Latent Database Print's Properties
View Recorded Database Print's Properties
Window Toolbars
Zoom Controls



Purchase Information

Sirchie offers the comPARAPrint family software in four configurations: comPARAFingerprint, 
comPARAPalmprint, comPARAPrint TECH+ and comPARAPrint TECH+ DB. 

comPARAFingerprint (CPARA5000L) is fingerprint only software, optimized for comparing latent and 
rolled finger impressions.

comPARAPalmprint (CPARA6000L) is palm print only software, optimized for comparing latent and 
rolled palm impressions.

comPARAPrint TECH+ (CPARA7000L) consists of both fingerprint and palm print software in a single 
package.

comPARAPrint TECH+ DB (CPARA7000LDB) consists of both fingerprint and palm print software in a 
single package, with a database capable of holding 500 latent and 500 recorded prints, and a fast search 
capability.

Contact Information:

Inquiries concerning this software should be addressed to 

Sirchie Finger Print Laboratories, Inc., 100 Hunter Place, Youngsville, NC 27596.

Voice: 800 356-7311
Fax: 800 899-8181
eMail: sirchie@mindspring.com
Web Site: http://www.Sirchie.com/



Flip Horizontal
display the image flipped left for right

The Flip Horizontal function applies to the whole image only.
1. With the Image Adjustment menu dropped, place the mouse over the option Flip Horizontal
Or
1a.    With the Image menu dropped, type H
2. if the image to be flipped is in the Recorded window, select Recorded or type R
Or
2a. If the image to be flipped is in the Latent window, select Latent or type L
The image is flipped horizontally (left for right).

Original image Image flipped horizontally

Flip Vertical
display the image flipped top for bottom

The Flip Vertical function applies to the whole image only.
1. With the Image Adjustment menu dropped, place the mouse over the option Flip Vertical
Or
1a.    With the Image menu dropped, type V
2. if the image to be flipped is in the Recorded window, select Recorded or type R
Or
2a. If the image to be flipped is in the Latent window, select Latent or type L
The image is flipped vertically (left for right).

Original image Image flipped vertically






